Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

Bilge pump

I am very new to boating and my boat so please excuse my ignorance.  I have a 2013 fun deck.  My bilge pump does not automatically turn on.  Can anyone supply me with information on where to check for the fuse and where to locate the bilge.  Would there be a user manual available as well?  Thanks in advance for the help.  Dan

Comments

  • nquirk
    nquirk Member, Moderator Posts: 674 ✭✭✭✭

    @Dan.. First congrats on becoming a boater and a Hurricane owner.

    First, when you manually turn on the pump does it run?  If not, you have a problem you'll need to contend with first.

    In the bilge area of your boat you should see the bilge pump.  Attached are 3 wires.  Two should run towards the helm of the boat (probably grouped together in a cable harness further up) and a single one with an inline 4A fuse running towards the battery.  Make sure that fuse is fine, and that the line is connected to the positive post of your battery and no corrosion, etc.


    ------------------------------------------------------------------------------
    2010 Hurricane SS 188 OB
    2010 Mercury Optimax 200HP / Mercury SS High Five 19P
    2010 Trailmaster SC trailer
  • rdcastle
    rdcastle Member Posts: 100 ✭✭✭

    Also, was the bilge pump originally set up for automatic operation?

    Rob Castle
    2001 Hurricane GS201 FD
    Yamaha 150 V6 2 Stroke, Oil Injection