Thank you so much for your involvement with the Owner's Club Forum! We hope you've gotten some great information and had the chance to interact with other owners on the current system.

Lost Master Power

We were out boating and hit a wake fairly hard.  When we did, we lost Master power.  We have checked all battery connections and they are fine.  Thought it might be the Master Power fuse, but I can't find it.  Does anyone know where the fuse would be?  Or any suggestions on what the problem may be?

Comments

  • cjjjdeck
    cjjjdeck Northern NJMember, Moderator Posts: 1,872 ✭✭✭✭
    I don't know what year and model Hurricane you have, but my 2012 SD237 has a circuit breaker button located directly below all the rocker switches, including the Master switch.  It may be a circuit breaker you need to find instead of a fuse.  If you give the year and model of your boat, maybe someone who has a similar model can help you better.
    2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
    2012 Load Rite Elite Tandem axle trailer

  • jwheeler
    jwheeler Member Posts: 3
    Thanks. It is a 2008 SunDeck 195.  There are circuit breaker buttons under all the accessory rocker switches but there is not one under the Master rocker switch.  We have checked the master fuses located off the battery and they are fine.
  • Ploening
    Ploening Member Posts: 4
    I had a similar problem. It turned out to be two issues. First check the 50 amp fuse that is just off the main battery connection (red lead). Make sure these two connecting nuts are tight. Second check the relays under the dash. They are two plastic 1" square boxes. Try to tap or squeeze the sides to activate the relay switch. They have been know to have problems and may need to be replaced. Peter 7/25/12
  • cjjjdeck
    cjjjdeck Northern NJMember, Moderator Posts: 1,872 ✭✭✭✭
    Update!

    I just had my boat at the dealer last week.  One problem I was having was that I couldn't operate more than one or two systems from the helm switches.  I also could hear what sounded like a relay struggling to activate.  The dealer found a bad male/female connection (looked like it corroded) on the main power harness back by the engine.  He said he's never encountered something like this on Hurricanes as these type connectors are rated water tight.  He's sending the bad connectors back to Hurricane to be evaluated.  I'm just thankful power at the helm was completely dead when he checked it as it was working intermittently for me (intermittent problems are absolutely the worst to diagnose!), so he was able to find the real problem. 
    2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
    2012 Load Rite Elite Tandem axle trailer

  • billdewberry
    billdewberry Member Posts: 2
    Greetings I know this is an old post but I have an immediate problem. I am planning going out for my first time in my 201GS Fundeck 02 Model. I just installed new dock lights. I hit the switch and all my dash accessories stop working except the Fuel and Battery gauge. All the breakers are out except the main, but they will not go back in. I have tightened the batter cables and the engine will start. I have no Radio, Lights, Livewell etc. Please help.
  • billdewberry
    billdewberry Member Posts: 2
    I actually found the blown fuse. Thank you for sharing your knowledge
    cjjjdeck wrote:

    I don't know what year and model Hurricane you have, but my 2012 SD237 has a circuit breaker button located directly below all the rocker switches, including the Master switch.  It may be a circuit breaker you need to find instead of a fuse.  If you give the year and model of your boat, maybe someone who has a similar model can help you better.


  • cjjjdeck
    cjjjdeck Northern NJMember, Moderator Posts: 1,872 ✭✭✭✭
    Glad you found it so quickly and it was an easy fix.

    Hopefully you have "spares" on board!

    2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
    2012 Load Rite Elite Tandem axle trailer

  • silvrfox
    silvrfox Member Posts: 1

    I lost power yesterday, 2008, 2400 sundeck.  I  can't open the motor hatch without power????????????????
  • cjjjdeck
    cjjjdeck Northern NJMember, Moderator Posts: 1,872 ✭✭✭✭

    Welcome to the Hurricane Owners Forum silvfox!

    Best to start a new thread as this one is over 6 months old.

    Click on this link to view a more current thread on the no power to the power hatch issue:

     http://hurricaneboats.vanillaforums.com/discussion/1466/power-engine-cover#latest

    That should help address your issue.

    2012 SD237 I/O Mercruiser 5.0L MPI ECT/ Bravo 3
    2012 Load Rite Elite Tandem axle trailer